Elektra coil issue

Tech Help, Restorations, Refurbishments, "Shop Out" Photos, Notes
Post Reply
pfcjimmy
Posts: 246
Joined: Sun Oct 19, 2014 11:18 am
Contact:

Elektra coil issue

Post by pfcjimmy »

I'm having an issue with the lower right saucer coil not firing.
Coil fails to fire during coil test. All other coils fire.

Things I've checked or done:
-Replaced the coil with a new one
-Voltage at the coil is fine
-Coil fires when I temporarily ground the non banded diode side
-New connectors for J4 and J5 on the driver board and J4 on the mpu (alltek mpu)
-Tested all wires between J4 of mpu and driver board
-Swapped out the driver board for an alltek one from a different game. I even swapped the mpu for another alltek mpu.

So far no luck in getting it to fire in game or in coil test.
Anything else I could check?
Last edited by pfcjimmy on Sun Feb 24, 2019 7:39 pm, edited 2 times in total.

Eric_S
Posts: 437
Joined: Sat Jan 18, 2014 9:02 am
Location: Neenah, WI
Contact:

Re: Elektra coil issue

Post by Eric_S »

Ground the tab of the transistor on the driver board to verify wiring from driver board to the coil. Grounding the tab should cause the the coil to energize.

pfcjimmy
Posts: 246
Joined: Sun Oct 19, 2014 11:18 am
Contact:

Re: Elektra coil issue

Post by pfcjimmy »

Grounding the tab as in grounding the metal part with the hole at the top of the transistor or grounding one of the legs (B-C-E)?

Eric_S
Posts: 437
Joined: Sat Jan 18, 2014 9:02 am
Location: Neenah, WI
Contact:

Re: Elektra coil issue

Post by Eric_S »

The tab is the big metal piece with the hole in the middle. Just ground it with a wire jumper to a ground braid momentarily.

pfcjimmy
Posts: 246
Joined: Sun Oct 19, 2014 11:18 am
Contact:

Re: Elektra coil issue

Post by pfcjimmy »

I grounded Q9 and the coil fires.
So the issue would be the wiring from MPU to driver board?

Eric_S
Posts: 437
Joined: Sat Jan 18, 2014 9:02 am
Location: Neenah, WI
Contact:

Re: Elektra coil issue

Post by Eric_S »

I would initially think that the issue would be a bad transistor or upstream IC chip in the driver board, but since you swapped a different board to no difference, it probably rules it out. I'd re-pin the connectors for the path from the MPU to the driver board. If that doesn't work, you'll need to use a meter to check voltages at the logic IC chips to see where the signal is.

pfcjimmy
Posts: 246
Joined: Sun Oct 19, 2014 11:18 am
Contact:

Re: Elektra coil issue

Post by pfcjimmy »

If you have a chance in the next few days could you post a picture of J4 from the MPU and driver board for comparison?
The first time I grounded the transistor it fired once during test mode but never again after that.

Eric_S
Posts: 437
Joined: Sat Jan 18, 2014 9:02 am
Location: Neenah, WI
Contact:

Re: Elektra coil issue

Post by Eric_S »

Mpu j4
Attachments
20190129_163634.jpg

Eric_S
Posts: 437
Joined: Sat Jan 18, 2014 9:02 am
Location: Neenah, WI
Contact:

Re: Elektra coil issue

Post by Eric_S »

I took a look at the schematics and the data from the MPU to the Solenoid Driver Board comes across five data lines to the decoder chip at U2 on the driver board (74LS154). Since all of the other coils work fine, I'm guessing the data from the MPU to the driver board is OK, otherwise I'd think other coils wouldn't be firing.

I would re-pin connector J5 pin 9 on the driver board and use a meter to verify continuity from Q9 to the coil. Otherwise, start troubleshooting the driverboard. Q9, U3 (transistor array that is now hard to find) and U2.

If grounding the tab on Q9 doesn't cause the coil to fire, then it is a wiring problem between the coil and driver board.

pfcjimmy
Posts: 246
Joined: Sun Oct 19, 2014 11:18 am
Contact:

Re: Elektra coil issue

Post by pfcjimmy »

Finally solved this by replacing the J3 connector on the MPU. This has the switch leaf wires for the coil.

Thanks for the tips Eric!

MikeS
Posts: 492
Joined: Thu Jun 20, 2013 3:54 pm
Location: Madison, WI
Contact:

Re: Elektra coil issue Solved

Post by MikeS »

Nice job Glad you got it fixed!
Current Collection: Rick and Morty, JPPrem, TWDLE, ACDC Prem, Alien Star, Diamond Lady, Space Invaders, Stars, Shadow, Sinbad, Eight Ball Champ.

Eric_S
Posts: 437
Joined: Sat Jan 18, 2014 9:02 am
Location: Neenah, WI
Contact:

Re: Elektra coil issue Solved

Post by Eric_S »

Congratulations on grating it fixed.

Post Reply